Ticker

6/recent/ticker-posts

Ad Code

Cisco Catalyst 3650 series switch Configuration

The Cisco Catalyst 3650 series switch is part of Cisco's enterprise-class switches and supports advanced features such as Power over Ethernet (PoE), stacking, and Cisco’s Unified Access. Below is a general guide for configuring a Cisco 3650 switch, covering basic initial setup, VLAN configuration, and IP addressing:

1. Initial Setup

First, connect to the switch via a console cable and use a terminal emulator (e.g., PuTTY, Tera Term, or Cisco’s own CLI tool). Follow these steps:

a. Access the CLI:

  • Once you connect, you should see the switch’s CLI prompt.
  • Enter privileged EXEC mode by typing enable.

b. Enter Global Configuration Mode:

configure terminal

c. Assign a Hostname:

To give the switch a unique name:

line con 0

password your_password

login

exit


enable secret your_enable_password


d. Set a Password:

To secure your switch, set a console and enable password:

line con 0

password your_password

login

exit


enable secret your_enable_password


2. Configure VLANs

VLANs (Virtual Local Area Networks) allow network segmentation. Here’s how to create and assign VLANs:

a. Create VLANs:

vlan 10
name Sales
exit

vlan 20
name HR
exit

b. Assign Ports to VLANs:

To assign a physical interface to a VLAN:

interface range fa0/1 - 10

switchport mode access

switchport access vlan 10

exit


Repeat this for other ports and VLANs as necessary.

3. Configure IP Addressing (Management VLAN)

To manage the switch remotely, assign an IP address to the VLAN interface that you will use for management (typically VLAN 1):

a. Assign IP to VLAN Interface:


interface vlan 1 ip address 192.168.1.2 255.255.255.0 no shutdown exit

b. Set the Default Gateway:

This is necessary for remote management:

ip default-gateway 192.168.1.1

4. Enable SSH for Remote Management

To manage the switch securely over the network, enable SSH access:

a. Configure the Domain Name:


ip domain-name example.com

b. Generate SSH Keys:


crypto key generate rsa general-keys modulus 2048

c. Enable SSH:


line vty 0 15 transport input ssh login local exit

d. Create a User Account for SSH Access:


username admin privilege 15 secret your_password

5. Save Configuration

Once you have finished your configuration, save the settings to the startup configuration file to ensure they persist after a reboot:


write memory

6. Verify Configuration

To check the VLANs, IP address, and SSH access:

  • Verify VLAN configuration: show vlan brief
  • Verify interface IP configuration: show ip interface brief
  • Verify SSH access: show ip ssh

Example Configuration Summary

Here’s an example configuration for a simple setup with two VLANs, management IP configuration, and SSH access:


hostname Switch3650 enable secret your_enable_password line con 0 password your_password login exit vlan 10 name Sales exit vlan 20 name HR exit interface range fa0/1 - 10 switchport mode access switchport access vlan 10 exit interface vlan 1 ip address 192.168.1.2 255.255.255.0 no shutdown exit ip default-gateway 192.168.1.1 ip domain-name example.com crypto key generate rsa general-keys modulus 2048 line vty 0 15 transport input ssh login local exit username admin privilege 15 secret your_password write memory

This configuration assumes you are using VLANs 10 and 20 and that your network’s default gateway is 192.168.1.1.





Post a Comment

0 Comments